読者です 読者をやめる 読者になる 読者になる

Windows7 64bitでPoint Cloud Library(PCL)1.5.1のインストール

PCL1.5.1のインストール方法が見つからなかったので、まとめてみます。

このエントリにPCL1.3.0のインストール方法が載っています。
DERiVE - 第2回改訂版:Point Cloud Library1.x(1.3以降)のインストール(Windows編)
が、1.5.1だと少し変更になっています。

変更点

Debug用ライブラリ(.lib)ファイルの名前

変更前

pcl_common-gd.lib
pcl_features-gd.lib
pcl_filters-gd.lib
pcl_io-gd.lib
pcl_kdtree-gd.lib
pcl_keypoints-gd.lib
pcl_octree-gd.lib
pcl_range_image-gd.lib
pcl_range_image_border_extractor-gd.lib
pcl_registration-gd.lib
pcl_sample_consensus-gd.lib
pcl_segmentation-gd.lib
pcl_search-gd.lib
pcl_surface-gd.lib
pcl_visualization-gd.lib
flann_cpp-gd.lib
flann_cpp_s-gd.lib

変更後

pcl_common_debug.lib
pcl_features_debug.lib
pcl_filters_debug.lib
pcl_io_debug.lib
pcl_kdtree_debug.lib
pcl_keypoints_debug.lib
pcl_octree_debug.lib
pcl_range_image_border_extractor_debug.lib
pcl_registration_debug.lib
pcl_sample_consensus_debug.lib
pcl_segmentation_debug.lib
pcl_search_debug.lib
pcl_surface_debug.lib
pcl_visualization_debug.lib
flann_cpp_s-gd.lib
flann_cuda_s-gd.lib

pcl_range_image-gd.lib(削除)

これだけで問題なく動くハズです。

また

プロジェクトが作成されたら、プロジェクトを右クリックしてプロジェクトのプロパティダイアログを開き、
「[構成プロパティ] > [文字セット]」を「マルチ バイト文字を使用する」に変更します。

と書かれていますが、今のところ変更しなくても問題なく動いています。
今後変更する必要がでてくるのかな?